Pages: [1]
  Print  
Author Topic: I cant run Spelunky!  (Read 9807 times)
PanostheGreat
Seedling
*
Posts: 5


View Profile
« on: July 07, 2012, 04:30:40 PM »

Whenever I try to run Spelunky.exe or Config this message pops up "Failed to initialize drawing sufaces. Please check that your graphics card meets the minimum requirements and that your drivers are up-to-date. If your graphics card has little memory, try switching your computer to a lower resolution." Well the thing is my card is an nvidia 9600 gt, 1gb card and i ve checked the requirement (minimum) and Im cool. I downloaded many times, I restarted, I updated my graphics card but still the same. I would appreciate any help Smiley
Logged
TyrOvC
Mossbaby
*
Posts: 424


This text is not random :(


View Profile WWW
« Reply #1 on: July 07, 2012, 04:44:51 PM »

Have you tried running Spelunky 1.2? It's compiled with Gamemaker 8.1 which fixes some hardware issues.

http://mossmouth.com/forums/index.php?topic=1257.0
« Last Edit: July 07, 2012, 05:02:33 PM by TyrOvC » Logged

Nathan
Mossy
*
Posts: 5088



View Profile Email
« Reply #2 on: July 07, 2012, 06:01:42 PM »

If that doesn't work go to the config file and change res
Logged

PanostheGreat
Seedling
*
Posts: 5


View Profile
« Reply #3 on: July 07, 2012, 07:36:22 PM »

I downloaded 1.2 as you advised but i had the same message plus it said it was an error -2005530516. I also lowered my ressolution to 800x600 but it still advices me to lower it. Well I've hit rock-bottom with 800x600 cant go any further! Tongue
Logged
TyrOvC
Mossbaby
*
Posts: 424


This text is not random :(


View Profile WWW
« Reply #4 on: July 07, 2012, 07:49:08 PM »

Do you have any graphics drivers installed that aren't the standard ones from NVIDIA for your card? And make absolutely sure that you've updated the lasted version of the drivers for your graphics card from the NVIDIA website.

Do you have any graphics settings anywhere (nvidia control panel?) forcing triple buffering on? If so turn off.

Run directx diagonostics to give us some more info:
Hold the Windows key and press R
Enter in the Open field : dxdiag
Hit Enter or click OK
The DXDiag panel should appear opened on the display tab, click the 'Save All Information' button at the bottom and post a copy of it here.
« Last Edit: July 07, 2012, 07:51:50 PM by TyrOvC » Logged

PanostheGreat
Seedling
*
Posts: 5


View Profile
« Reply #5 on: July 08, 2012, 05:20:46 AM »

In the nvidia panel (which is in my language) there was this thing called "triple saving in mid memory" (I translated it to english just now) and since its the only phrase that starts with the word triple Im guesing thats it xD. So anyways it was turned off already. As for the DxDiag its super big to post so Ill just post the system information and the display devices part (except if you need more then I'll post it all). Im sry for this long post please tell me if you need more Smiley

DxDiag System Information

Time of this report: 7/8/2012, 14:02:14
       Machine name: USER-PC
   Operating System: Windows 7 Ultimate 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120330-1504)
           Language: Greek (Regional Setting: Greek)
System Manufacturer: Acer           
       System Model: Aspire 8730                   
               BIOS: Ver 1.00PARTTBL
          Processor: Intel(R) Core(TM)2 Duo CPU     P7450  @ 2.13GHz (2 CPUs), ~2.1GHz
             Memory: 4096MB RAM
Available OS Memory: 3066MB RAM
          Page File: 1522MB used, 4609MB available
        Windows Dir: C:\Windows
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
   User DPI Setting: Using System DPI
 System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
     DxDiag Version: 6.01.7601.17514 32bit Unicode

Display Devices

Card name: NVIDIA GeForce 9600M GT               
       Manufacturer: NVIDIA
          Chip type: GeForce 9600M GT
           DAC type: Integrated RAMDAC
         Device Key: Enum\PCI\VEN_10DE&DEV_0649&SUBSYS_017E1025&REV_A1
     Display Memory: 2285 MB
   Dedicated Memory: 1007 MB
      Shared Memory: 1277 MB
       Current Mode: 1920 x 1080 (32 bit) (60Hz)
       Monitor Name: Οθόνη PnP γενικής χρήσης
      Monitor Model: unknown
         Monitor Id: CMO1803
        Native Mode: 1920 x 1080(p) (59.999Hz)
        Output Type: Internal
        Driver Name: nvd3dum.dll,nvwgf2um.dll,nvwgf2um.dll
Driver File Version: 8.17.0013.0142 (English)
     Driver Version: 8.17.13.142
        DDI Version: 10
       Driver Model: WDDM 1.1
  Driver Attributes: Final Retail
   Driver Date/Size: 5/15/2012 13:26:00, 15322432 bytes
        WHQL Logo'd: Yes
    WHQL Date Stamp:
  Device Identifier: {D7B71E3E-4509-11CF-1B73-73211FC2C535}
          Vendor ID: 0x10DE
          Device ID: 0x0649
          SubSys ID: 0x017E1025
        Revision ID: 0x00A1
 Driver Strong Name: oem1.inf:NVIDIA_SetA_Devices.NTx86.6.1:Section006:8.17.13.142:pci\ven_10de&dev_0649&subsys_017e1025
     Rank Of Driver: 00E60001
        Video Accel: ModeMPEG2_A ModeMPEG2_C ModeVC1_C ModeWMV9_C
   Deinterlace Caps: (At this point theres a long list of numbers and letters in brackets)
D3D9 Overlay: Supported
            DXVA-HD: Supported
       DDraw Status: Enabled
         D3D Status: Enabled
         AGP Status: Enabled
Logged
TyrOvC
Mossbaby
*
Posts: 424


This text is not random :(


View Profile WWW
« Reply #6 on: July 09, 2012, 02:18:46 PM »

Okay, the only thing I can suggest to do at this point is either

A) Download DirectX Software Development Kit and use
/Utilities/bin/x86/dxcpl.exe 
to disable DirectX using hardware acceleration for display graphics. Be sure to turn it back on to play any game other than Spelunky.

B) Download and try Beta drivers for your graphics card. May have to roll back to stable drivers if it causes even more issues. If a Beta driver doesn't make it run, rollback.

Both things are rather in depth.

Unfortunately, the rendering system Spelunky uses, and is preventing it from working on your computer (Gamemaker Surfaces) would take a lot of work to remove from the code and use something that might work on your computer. It's possible to mod it to work, but I personally don't have the time to do so right now.
Logged

PanostheGreat
Seedling
*
Posts: 5


View Profile
« Reply #7 on: July 09, 2012, 06:49:52 PM »

I downloaded the program as you said but there a lot of stuff when I open the .exe and I didnt find a clear "Disable direct x" option (except if I didnt saw it) I dont think I'll try the rolling back though. I appreciate your help, you have been really helpfull thank you! Cheesy So if you could do me this last favor and spell it out for me on how to disable it, it would be realy great! Smiley
Logged
TyrOvC
Mossbaby
*
Posts: 424


This text is not random :(


View Profile WWW
« Reply #8 on: July 14, 2012, 12:39:54 AM »

Sorry I haven't got back to you, been busy and haven't checked these forums. I'll get more detailed instructions posted tomorrow.
Logged

PanostheGreat
Seedling
*
Posts: 5


View Profile
« Reply #9 on: July 17, 2012, 01:44:01 PM »

I'm all ears! Cheesy (Or eyes, whatever... Tongue )
Logged
TyrOvC
Mossbaby
*
Posts: 424


This text is not random :(


View Profile WWW
« Reply #10 on: July 22, 2012, 02:16:33 PM »

After you install the directx development kit, look in

"Program Files\Microsoft DirectX SDK (Version you downloaded)\Utilities\bin\x86"

For example, mines in:
"F:\Program Files\Microsoft DirectX SDK (June 2010)\Utilities\bin\x86"

Double click and run "dxcpl.exe"

You should see a thing pop up that looks like



Under direct draw uncheck Use Hardware Acceleration.
« Last Edit: July 22, 2012, 03:01:03 PM by TyrOvC » Logged

KarjamP
Mossy
*
Posts: 3684


Meet Miijam!


View Profile WWW Email
« Reply #11 on: July 22, 2012, 02:48:24 PM »

Typo:
"Program Files\Microsoft DirectX SDK (Version you downloaded\Utilities\bin]x86"

You also forgot to close the bracket of (version you download)
Logged

Meet Bodyless!

3DS friendcode: 4210 - 4681 - 1626



Join Dropbox!

BTC: 1M7MKFdwwrDqqowMUkrCXKhcEi7a16pwWy
Pages: [1]
  Print  
 
Jump to: