Pages: [1]
  Print  
Author Topic: disappearing shotgun  (Read 3245 times)
DialFforFunky
Bean
*
Posts: 129


Revenge of the Burning Yeti


View Profile
« on: May 11, 2012, 04:50:29 PM »

just got a weird bug in the ice levels. I was minding my own business, flying around with my cape and shotgun, when all of a sudden I got these error messages repeated over and over:

___________________________________________
ERROR in
action number 3
of  Step Event
for object oPlayer1:

Error in code at line 84:
       if (holdItem.type == "Machete")
                    ^
at position 19: Unknown variable type

___________________________________________
ERROR in
action number 9
of  Step Event
for object oPlayer1:

Error in code at line 23:
       if (holdItem.type == "Bow")
                    ^
at position 19: Unknown variable type

___________________________________________

They would stop at some point, but returned after a second or two. Oh, and my shotgun had disappeared. Needles to say, I ended up falling in the pit at the bottom of the screen, shoppy hot at my heels. Luckily, of the shoppy, me, and the error message, I was the only one to get revived by the ankh. Still, one of the weirdest errors I had in a long, long time. Anyone know what went wrong?


F

p.s.: at roughly 340 finishes Smiley
Logged

Kegluneq
Big Bossy
Mossy
*
Posts: 2260



View Profile Email
« Reply #1 on: May 31, 2012, 12:47:16 PM »

Good god, the horrible machete/bow bug.
You were just flying around? Didn't get hit by anything?
Logged

A wild SHINY MOSSY appeared!
DialFforFunky
Bean
*
Posts: 129


Revenge of the Burning Yeti


View Profile
« Reply #2 on: June 01, 2012, 06:36:23 PM »

Just enjoying my cape glide, not even touching any terrain (I was near-ish, but still at least a spelunky-length away). It's probably the weirdest error I've had.


F
Logged

Kegluneq
Big Bossy
Mossy
*
Posts: 2260



View Profile Email
« Reply #3 on: June 01, 2012, 09:10:39 PM »

Ugh yea, I ran into it all the time back when I was working on the multiplayer mod, I never did find the root of the problem, although item possession seemed to play a role.
« Last Edit: June 03, 2012, 12:14:08 PM by Kegluneq » Logged

A wild SHINY MOSSY appeared!
DialFforFunky
Bean
*
Posts: 129


Revenge of the Burning Yeti


View Profile
« Reply #4 on: June 03, 2012, 07:04:08 AM »

I guess that should be in the right direction. Ice levels always seem to have issues with items. Thanks for the response.


F
Logged

Pages: [1]
  Print  
 
Jump to: