Pages: [1]
  Print  
Author Topic: Can't Use Gamepads w/ Spelunky  (Read 5511 times)
Dragoonkin
Seedling
*
Posts: 6


View Profile
« on: December 30, 2010, 10:09:10 AM »

Okay so...I have two gamepads, an old USB Sidewinder, and a new Xbox 360 controller and NEITHER of them will work with Spelunky, at all.

I've tried setting them up with the control configurator and that doesn't work, but even with just the base settings I can't even make the D-pad work in-game.

Anyone have any ideas on what's up here?
Logged
Kegluneq
Big Bossy
Mossy
*
Posts: 2258



View Profile Email
« Reply #1 on: December 30, 2010, 05:04:29 PM »

You did check the "Use Gamepad" check-box in the config right?
Logged

A wild SHINY MOSSY appeared!
Dragoonkin
Seedling
*
Posts: 6


View Profile
« Reply #2 on: December 31, 2010, 02:21:30 PM »

Yep. Double-checked again right now to make sure.
Logged
Kegluneq
Big Bossy
Mossy
*
Posts: 2258



View Profile Email
« Reply #3 on: January 01, 2011, 02:53:02 AM »

And your clicking joy config, not key config?
I know these are pretty dumb questions, I'm just trying to rule out any possibilities of mistakes.

Also, I have a 360 controller myself and it works just fine (although it is gamestop's and not microsoft's).

One more idea: Is your computer even registering it as plugged in? It's possible your USB port may be jacked or something. Go into the control panel to ensure you're controller is connecting, and that it's drivers are up to date.

If nothing I said is the problem, then there's always JoyToKey. Google it.
Logged

A wild SHINY MOSSY appeared!
Dragoonkin
Seedling
*
Posts: 6


View Profile
« Reply #4 on: January 01, 2011, 11:08:15 PM »

Yep, Joy Config.

Yep, plugged in. I use them in other games fine. Just Spelunky refuses to see them. Same Xbox controller I use for Super Meat Boy.

Even says "Joy 1 / Joy 2 Found!"

The D-pad doesn't even work, despite the fact there's no option to rebind those.
Logged
Kegluneq
Big Bossy
Mossy
*
Posts: 2258



View Profile Email
« Reply #5 on: January 02, 2011, 12:45:48 AM »

Then I'm all out of ideas. Sorry!
Logged

A wild SHINY MOSSY appeared!
Moloch
Mosskid
*
Posts: 546


View Profile WWW
« Reply #6 on: January 02, 2011, 01:00:28 PM »

I play Spelunky with an old Gravis gamepad without any problems, and I can't think of what would be going wrong either.

Even says "Joy 1 / Joy 2 Found!"

(Random idea) Try having only one gamepad plugged in at a time.


EDIT: Is it just the d-pad that doesn't work?
« Last Edit: January 02, 2011, 01:08:35 PM by Moloch » Logged

Arucard
Mossy
*
Posts: 2811


Hey! Is that CANDY?!?!?

Arucard.Tepes
View Profile Email
« Reply #7 on: January 02, 2011, 04:45:53 PM »

Well SMB is set up to work specifically with 360 controllers, that may be part of the problem. Perhaps the 360 controller is not configured to work with game maker? And the other is...too old? Try them with another GM game that uses gamepads if you can find one.

I have always used Logitech controllers, and both have worked from beginning for me. With a little tweaking of the gamepad.cfg
Logged

Oh, they look like monsters to you?

There's a light in the darkness of everybody's life.
Dragoonkin
Seedling
*
Posts: 6


View Profile
« Reply #8 on: January 05, 2011, 12:52:12 AM »

I play Spelunky with an old Gravis gamepad without any problems, and I can't think of what would be going wrong either.

Even says "Joy 1 / Joy 2 Found!"

(Random idea) Try having only one gamepad plugged in at a time.


EDIT: Is it just the d-pad that doesn't work?

Nothing works. I only have one gamepad plugged in. That boggles me even more. I'm going to see if there's some USB device it thinks-is-a-gamepad that's eating the controls.

Edit: Unless it's my mouse I have no idea what joystick it thinks is plugged in. I have a Logitech G13 (keyboard), keyboard, mouse, and printer in USB. I unplugged everything but my mouse (so I could click the button) and it still said "Joy 1 Found!"

So now I appear to have found the problem: Spelunky thinks I have a ghost joystick plugged in somewhere and won't let me use the controls for "Joy 2".
« Last Edit: January 05, 2011, 12:56:54 AM by Dragoonkin » Logged
Kegluneq
Big Bossy
Mossy
*
Posts: 2258



View Profile Email
« Reply #9 on: January 05, 2011, 10:48:29 PM »

I still say you should try JoyToKey
Logged

A wild SHINY MOSSY appeared!
Dragoonkin
Seedling
*
Posts: 6


View Profile
« Reply #10 on: January 06, 2011, 10:23:59 PM »

My problem with Joy2Key is I can't find any "deadzone" option on the analogue stick, so just the barest barest touch makes me fling across the screen.

Is there a "deadzone" option for analogue sticks hidden in there somewhere?
Logged
Dragoonkin
Seedling
*
Posts: 6


View Profile
« Reply #11 on: January 15, 2011, 11:44:12 PM »

Fixed the problem myself, for reference for future people who may have this issue:

The issue is, Spelunky sees my gamepad as controller #2, so it doesn't let me bind to it.

How to fix this in Windows 7:

Start Menu > Devices and Printers

Then select the game controller you want to use (Xbox 360 Controller for Windows in my case), right-click and select "Game Controller Settings". A dialogue should pop up with all your game controllers listed. In my case, it was seeing my Logitech G13 as a game controller as well as a keyboard.

Press the "Advanced..." button, and a dropdown window will appear letting you "Select the device you want to use with older programs." Pick the controller you want, this one will now be "Joy1".

That's it, now you can bind your controller and be happy. Wink

Hopefully this helps someone sometime.
« Last Edit: January 15, 2011, 11:50:47 PM by Dragoonkin » Logged
Kegluneq
Big Bossy
Mossy
*
Posts: 2258



View Profile Email
« Reply #12 on: January 17, 2011, 08:39:19 PM »

Good job troubleshooting!

In response to your question, yes there is a deadzone option. On the right side of the main screen is an options tab, the deadzone option is in there.
Logged

A wild SHINY MOSSY appeared!
Pages: [1]
  Print  
 
Jump to: